Дозрів до налаштування резервного каналу інтернет.

Досі використовувався бюджетний D-Link DIR-320, в якому лише один аплінк. Тобто коли треба було переключитися на іншого провайдера, це робилося руками. Шукав світч, де би було два і більше аплінки, а також можливість підключити usb-модем (бажано теж більше одного).

Зупинився на Mikrotik RB450, котрий знайшов на olx. Дещо вже застаріла модель, бо підтримує лише 100 мб/c (однак місцевий провайдер більше не пропонує), а також нема usb порта (вирішив за допомогою підключення Zyxel Keenetic). 

undefined

Спершу мені не по зубах було налаштування мікротіка і я знайшов на тому ж olx місцевого майстра. 

Чемно переключається з основного на резервний канал. І назад.

Значить в мене на eth1 по ppoe конектиться до провайдера, котрий заходить в хату по езернету.
Там єдиний мінус - що при відновленні з'єднання ppoe не відразу ж піднімається, не знаю чи це підлягає покращенню.
Мабуть це особливість технології ppoe.

На eth2 в мене Zyxel Keenetic 4G. На тому ж olx знайшов. Брав щоб налаштувати usb модем(и).
Досить просто піднявся kyivstar, правда в мене від нього в наявності лише 2G модем ZTE і швидкість відповідно низька.
Втикнув Novatel Rev.A від intertelecom - взагалі нема нарікань, ну ще би знайти Rev.B щоб було ще краще.
Біда-печаль, що мій ноунейм модем від "ватафону" (Vodafone) при нагріванні після деякого часу роботи пропадає.
Бо на ватафоні найсмачніший тариф, якраз для мене: 500 мб на день за 5 грн на місяць (і найкрутіша швидкість серед випробуваних - в зоні дії 3g, щоправда, котра поки що лише в великих містах і в деяких ще точках).
Тобто якраз для ситуацій, коли основний інтернет пропадає ненадовго і рідко.
Мабуть що це вирішується шляхом пошуку розлоченого usb модему, ну цим пізніше займуся.
Лайф usb не пробував, хоча чув що там доволі хороші показники, може колись.
Укртелеком usb не пробував і мабуть не збираюся.

А, ну ще веб-інтерфейс Zyxel Keenetic говорить, що там можна підключати декілька модемів одночасно і виставляти пріоритетність.
Ну не знаю, usb-порт там лише один, я пробував через різні usb-хаби і лампочки модемів весело миготять, от тільки в такому варіанті Zyxel їх взагалі не бачить.
Може ще спробую пізніше usb-хаб із зовнішнім живленням, може їм на декількох не вистачає тих міліампер, котрі видає Zyxel.

"Нормального" резервного провайдера не знайшов в себе.
Є один, в якого основний хліб це кабельне телебачення, на нього жаліються що інтернет з 90-х років.
Є ще "ОГО-го", який колись давно в мене був недовго і більше не хочеться.
Є ще якийсь радіо-інтернет, для якого треба купити обладнання для під'єднання.
А потім невідомо, що з ним робити, якщо не сподобається.
Так що пачка usb-модемів - нормальний варіант на запас.

Теоретично ще буду в перспективі зацікавлений в можливості налаштування "змішування" трафіку від різних провайдерів в один канал (коли з'явиться ще один ethernet провайдер в будинку).
Але зараз режим переключання з основного на резервний канали повністю влаштовує.

Через деякий час розібрався самостійно, як налаштувати перевірку доступності основного каналу базуючись на пінгу 8.8.4.4 (днс гугл). 

В разі питань - прохання писати в коментарях, при нагоді доповню даний допис.

Нижче подаю повний експорт з мого мікротіка. 

/interface ethernet

set [ find default-name=ether1 ] comment=WAN name=ether1_PPPoE

set [ find default-name=ether2 ] name=ether2_Zyxel

set [ find default-name=ether3 ] name=ether3_WAN3

set [ find default-name=ether4 ] comment=LAN name=ether4_masterLAN

set [ find default-name=ether5 ] master-port=ether4_masterLAN

/interface pppoe-client

add disabled=no interface=ether1_PPPoE name=pppoe-out1 password=mypass1 use-peer-dns=yes user=myuser1

/ip neighbor discovery

set ether1_PPPoE comment=WAN

set ether4_masterLAN comment=LAN

/ip hotspot user profile

set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d

/ip pool

add name=dhcp_pool1 ranges=192.168.88.10-192.168.88.254

/ip dhcp-server

add address-pool=dhcp_pool1 disabled=no interface=ether4_masterLAN name=dhcp1

/port

set 0 name=serial0

/ip address

add address=192.168.88.1/24 interface=ether4_masterLAN network=192.168.88.0

/ip dhcp-client

add default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether2_Zyxel

/ip dhcp-server network

add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1

/ip dns

set allow-remote-requests=yes servers=192.168.1.1,8.8.8.8

/ip firewall filter

add chain=input comment=Allow_ping protocol=icmp

add chain=forward protocol=icmp

add chain=input comment=Accept_established_connections connection-state=established

add chain=forward connection-state=established

add chain=input comment=Accept_related_connections connection-state=related

add chain=forward connection-state=related

add action=drop chain=input comment=Drop_invalid_connections connection-state=invalid

add action=drop chain=forward connection-state=invalid

add chain=input comment=Allow_UDP protocol=udp

add chain=forward protocol=udp

add chain=forward comment=Acces_to_Internet_from_local_network src-address=192.168.88.0/24

add chain=input comment=Access_to_Mikrotik_only_from_our_local_network src-address=192.168.88.0/24

add action=drop chain=input comment=All_other_drop

add action=drop chain=forward

add action=reject chain=output disabled=yes dst-address=8.8.4.4 reject-with=icmp-host-unreachable

add action=reject chain=output disabled=yes dst-address=8.8.8.8 reject-with=icmp-host-unreachable

/ip firewall mangle

add action=change-mss chain=forward in-interface=ether2_Zyxel new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535

add action=change-mss chain=forward new-mss=1452 out-interface=ether2_Zyxel protocol=tcp tcp-flags=syn tcp-mss=1453-65535

/ip firewall nat

add action=masquerade chain=srcnat out-interface=pppoe-out1

add action=masquerade chain=srcnat out-interface=ether2_Zyxel

/ip firewall service-port

set tftp disabled=yes

set irc disabled=yes

set h323 disabled=yes

set sip disabled=yes

set pptp disabled=yes

/ip route

add check-gateway=ping distance=1 gateway=8.8.4.4

add disabled=yes distance=1 gateway=10.10.10.1

add distance=1 dst-address=8.8.4.4/32 gateway=10.10.10.1 scope=10

/ip service

set telnet disabled=yes

set ssh address=192.168.88.0/24

set api disabled=yes

set api-ssl disabled=yes

/system clock

set time-zone-name=Europe/Kiev

/system clock manual

set time-zone=+03:00

/tool e-mail

set last-status=failed